OSD and SAN Disks

image Working with a customer recently, they had an issue using SAN attached disks during Operating System Deployment. They could successfully create and format the SAN attached disk as the D drive during the WinPE portion of the task sequence, but the disk would go offline during the Windows 2008 mini-setup. This was causing a major issue because they were directing the install of the ConfigMgr client to the D drive. This step was obviously failing because the disk was offline. Also, because there are no steps between the mini-setup and installation of the agent, there is no way to inject a diskpart script or any other command.

After working with CSS a little, the customer discovered a setting in the unattend.xml that could be adjusted to force Windows to bring all SAN attached storage online: SANPolicyType.One additional issue they ran into is that the WAIK documentation states that the default value for this policy is to “mount all available storage devices” – they weren’t seeing this behavior in practice though. If you reference the MSDN documentation on the underlying Windows configuration setting that is controlled by this setting in the unattend.xml though, the default setting for Windows 2008 Datacenter and Enterprise is actually to “mount all storage devices except those on a shared bus”. Once they figured this out and added the setting to their unattend.xml, everything clicked into place.

(All credit for the above info goes to Chris P at the anonymous customer.)

Leave a Reply

x

We use cookies to ensure the best possible experience on our website. Detailed information on the use of cookies on this site is provided in our Privacy and Cookie Policy. Further instruction on how to disable our cookies can be found there.