No Network Connection when adding a Media Center Extender

For years I have been using my Microsoft Media Center computer and my Xbox systems to provide access to media in my home. This system started as Windows XP and has been upgraded through the years until its recent upgrade to Windows 8.1. During this upgrade process I lost the ability to stream media from the Media Center to my Xbox 360’s as extenders. Whenever I attempted to add an Xbox as an extender I received the following message on the Media Center:

"No Network Connection. Your PC is not connected to a network. To continue Setup, connect the PC to your network, then select Next to try again." as shown below. This occurred when attempting the first step of the extender configuration which is "Configuring Computer Settings". What makes this doubly-strange is that in the Media Center user interface it indicates that it does see the Xbox 360 as an extender but it still cannot connect to it correctly (to validate this was the same Xbox, it shows three of the eight numbers displayed on Xbox 360 when establishing it as an extender).

Xbox extender error.JPG

A corresponding error was created in the Media Center log event ID 524 each time an attempt was made to add the extender as shown below. The following is the message in the event log:
"Your Windows Media Center PC must be connected to a network to communicate with your Media Center Extender." as shown below.

The message is strange because there is a network adapter, it is connected to the system and the system can browse the web on the system without issues.

The following is a summary of attempts to debug and resolve this issue that I had attempted with no success:

  • There were two network adapters on the system. The first was unplugged. Tried plugging in the first network adapter instead of the second.
  • Disabled network adapters.
  • Changed firewall configurations.
  • Re-enabled the original adapter, plugged it in instead of the second connection and re-try.
  • Plugged in both network adapters.
  • Made the MCX account a local administrator.
  • Removed from the domain and ran the system in a workgroup.
  • Deleted the network adapters from device manager and rebooted the system.

Fixing the connection to an extender:

The hint for the root cause was in the active networks on the system. There were no active networks displayed in the Network and Sharing Center. This was in contrast to my laptop which did list active networks. Every article I found indicated that these could be configured from the within Windows 8.1 but these options were not available on my system. (There was no "Find devices and content" available within my system). Articles that I worked form included:

The answer was found at: In case this link ever disappears, here’s the steps which were required:

In regedit, go to HKLM->SOFTWARE->Microsoft->Windows NT->Current Version->NetworkList

Rename Profiles to Profiles123 (or something other than Profiles) and rename Signatures \ Managed to Managed123 (or something other than Managed). Refresh the content on the Network and Sharing Center (or reboot) and active networks now appear after the system rebuilds the registry keys within Profiles and Managed sections of the registry.


The original registry keys are shown as renamed below, and the new Profiles and Managed were auto-created by Windows after rebooting or restarting the Network List Service.

Prior to the change nothing had appeared as a valid network for this system. After the change, the network connections now appeared as public.

After this, I used a PowerShell script to make the public networks on the system to be private networks: (I don’t know if this was actually required, but I’m including the step just in case).

Now that the active network existed, I re-ran the extender connection and it worked like a champ!

Summary: If you are receiving a message that "No Network Connection" exists when attempting to add an Xbox as a media extender and you have the ability to browse from your system check and see if the Network and Sharing Center on your system shows an active network. If it does not, take a look into this blog post for details to resolve the issue.

Leave a Reply